Google
 
ネットワーク
たぶねこ @ 2007年5月20日 4:57 PM

現在クライアントでおきている問題だけど、カナリ八方塞状態・・・
まずは、状況の確認から・・・

対象のサーバー(postfix)を使用してメールを送信する際、
・サーバー設置場所からのメール送信は可能。(添付も可)
・自宅からのメール送信は可能。(添付も可)
・自社からメールを送信した場合は、Relay access deniedで廃棄される。
・問題の送信元からの送信では、一言メッセージ程度のメール送信は可能。添付ファイルやちゃんとした文章を記入したメールを送ろうとするとタイムアウト(Outlook Expressで0×800ccc0f)が発生。送信済みトレイへの移動も失敗。

それぞれの設置場所の条件の違いは次のとおり。
・サーバー設置場所 ISP ASAHI-NET(固定IP)
・自宅 ISP ASAHI-NET(固定IP)
・自社 ISP DTI(固定IP)
・問題の送信元 ISP ASAHI-NET(固定IP)

この状態だと、自宅と問題の送信元の違いは、サーバー設置場所と件が違う位の差しかありえない。他に違いはあるかと言うと、問題の送信元では、大量のLAN配線を行っている点くらいでしょうか?
某F社のHUBを使用しているらしいですが、そこの工事がカナリいい加減だったと言う事はありますが、pingでパラメータに大き目のサイズを設定して送信しても特に問題はなかったので、1kB程度のメールが送れないと言うのも変ですよね。

OP25Bが原因かと思ったのだが、ISPが言うには、次のいずれかに当てはまっている場合は、25番ポートでの送信が可能であるようです。
・ISPのメールサーバに中継する。
・固定IPアドレスを使用する。
・ISPのメールサーバを利用する。

 ・・・ってことらしいが、固定IPで運用している時点で、ISPの要件は満たしているにもかかわらず送信出来ないと言う状況。

いったいどうしたらいいものか・・・


(一個進展)
自社から送信した際にRelay access deniedしてしまっていたのは、自社ではメールソフトに「Thunder Bird」を使用していたからです。バグがあるとかそういう事ではなく、単に設定の仕方を理解していなかっただけで、SMTP認証で、TLSを使用しない際に、ID・パスの設定をしなくても大丈夫だと考えていたのですがどうやら必要だったようです。ID・パスを設定したら送信が可能になりました。

(解決間近・・・?)
その後、いろいろとチェックしてみましたので、状況を整理してみました。
[自分で試して見た事]
・送信を行うメールソフトの設定チェック。
 - SMTP-AUTHの設定確認。
  [×] 特に問題なく設定されている。
 - 送信サーバーをプロバイダのメールアドレスに変更。
  [○] プロバイダのメールだと送信が可能のようだ。(・・・けど、それじゃ意味ないし)
 - タイムアウトを最大にしてみる。
  [×] 待つ時間が長くなるだけで
・サーバーのチェック。
 - 他のサーバーとの設定を比較。
  [×] 初期設定の違いで、設定されている項目に違いがあるが、問題はないと思われる(ちといい加減)
 - プロバイダのメールサーバーへの転送設定。
  [×] なぜかうまくいかない。smtp-authを自サバとプロバイダの両方でチェックされる場合どうやるの??
 - ログの確認。
  [×] いっさいメールログに残っていない。・・・この場合サーバーまでたどり着いていないって事なのか?
・ルータ(Web Caster V110)の設定チェック。
 -マニュアルを確認して影響しそうな設定を確認。
  [×] ステルス設定というTCPポートをガードする設定があるらしいが、特に影響はなかった。
 -2台ある同一ルータのもう一台を使用して送信確認。
  [×] やはり同じ状態。
・他のサーバーのメールアドレスを追加
  [×] プロバイダ以外のメールアドレスは、たとえゾーン逆引きが出来ても受け付けてくれない。
     (ただし、あくまで自作のサーバーに限った話。まだ、サーバーの設定が100%正しいとは断定できない
      ・・・多分どんだけやっても、自分を信用はしきれないんだろうけどね。) 
・藁にもすがる思いで、別のルータ(バッファロー WHR-G54S)に設定を行ってみた。
  [○] まるっきり問題なしで、送信可能!

・・・こうなるとルータの問題としか思えないが、念のためプロバイダとルータのメーカへ状況の説明をして、対応策を考えてもらう事にした。
 

[プロバイダへ確認して判った事]
・OP25Bは、フレッツに対しては行っていない。
  [×] 対応ロジックはコメント化(似たような状況の事例がネット上で見つかったので、はずしてみたが、影響なし)
・同様の事例(詳しくは教えてもらえなかったが)で、ルータを工場出荷時の状態に戻し、再設定を行いメール送信が可能になった事がある。
  [×] やはり変わらない。

[ルータのメーカーへ確認して判った事]
・メール送信に関する設定はないとの回答。
  (他の機器の確認をさせようと話を進めるので、他の設定がどうあれ、ルータが原因で現在の状況にある事を説明。)
・もしかすると、NAPTで許可するとうまくいくかも・・・(ありえないような気もするけどいちよう試してみた結果)
  [×] やはりありえなかった。それにLAN側を限定してしまうんじゃ、正対処とは言えないしね。

ここまでの状態で、しばらくは、バッファローのルータを使って頂く事として、ルータメーカーの故障担当に、
状況の確認をしてもらうために来てもらうことになりました。
・・・ちゃんと詳しい人が来てくれる事を願うばかりです・・・

(そして結果)
本日故障担当の方が来られました。新品の機器を持ってきて設定データを移し替えて試してみたりしていましたが、結局ダメ。購入後まだ1ヶ月と言う事でしたし、機種をクライアントが選んだわけでもなく用途を説明したにもかかわらず送られたものが、はじめから使い物にならなかったという点を考慮して、故障担当者は返品で受けようとしていたのですが、返品を受け付ける担当は、注文を受けた担当者らしく、故障担当者が電話すると、購入した物は返品は受け付けないの一点張り・・・機器担当者に伺った話ですが、NTTの機器はレンタルなら交換やレンタルの中止は簡単に受け付けてくれるらしいですが、購入すると返品は難しいようです。・・・(??)なんか変。
延々2、30分またまた最初から状況を説明する事になり、しまいにはクライアントが激怒してしまい、かわいそうな故障担当は平謝り。ビビリながら、返品を訴え続けるが、次に帰ってきた回答は「すぐには回答できないので、後日改めて回答する。」と言う時間稼ぎにも似た回答。そんな答えでクライアントも納得するはずもなく一蹴。それでも更に返品受付の担当者は「今日中に回答する。」となんとしてもすぐに回答したがらない。故障担当者もう泣き出しそうな顔をしながら、恐る恐るクライアントにその事を告げるが一言で却下。最終的には返品は受付られたのだけれど、代替のルータに付いては、故障担当者がすがる様な目でお願いされてしまったので、流石にかわいそうになっておいらが用意と設定をする事でいちようの解決となりました。ここまでのおいらの労力ほぼただ働き+交通費+人件費のマイナス。金銭面では損をしましたが、NTTと言うところがどういうところなのか実感できたり、ルータの設定やネットの状況確認などイロイロと覚えられてそれなりに満足な作業でした。

しかし、NTTもいい加減部署間でのお役所仕事的な対応はやめて欲しいですよね。高々1台のルータの問い合わせに、設定担当、機器担当、故障担当、返品担当と4段階もあり、それぞれの担当者に、どういう使い方をして何が出来ないのか説明をして、前に聞いた担当者にどういう設定を試すように言われてその結果を伝えないと受け付けてくれないし、そこから先も妥協せずに訴え続けないと責任取らない方向に話を進めようとするし・・・これからはクライアントに通常の利用に耐えうる事が確認取れるまでは、NTT機器の購入は勧めないようにしますよ(??)ま、今回もクライアントが独自で購入したものでだったけどね。それを自分で設定しようとしてて、設定方法をおいらに聞いてくるものだからそれなら直接設定したほうが早いので・・・って言ってしまった事で今回の騒動に巻き込まれちゃったという。完全にもらい事故のような話でしたとさ(??)

2件のコメント »

  1. こんにちは。はじめましてktanaka@ASDと申します。

    タイトルの「Web Caster V110におけるメールの送信時間切れ問題」の内容で

    以下の点について差し支えなければ教えていただけませんでしょうか。

    1.問題の環境から、全ての相手先に対して同様の送信障害がでるのでしょうか。
    2.PostFixのバージョン。
    3.Web Caster V110のファームウェアのバージョン。

    自分の抱えている案件で、ほぼ同様の構成で「特定の相手先へのみ送信ができない」
    現象が発生していて、現在調査している状況です。
    (1k程度のメール送信は可能で、大きなデータサイズのメールは送信できません。)

    何ヶ月も前の件で、大変恐縮ですがご返事に期待します。

    コメント by ktanaka@ASD — 2007年8月15日 @ 1:30 PM

  2. はじめまして。管理人のたぶです。

    おいらの時とはちょっと状態が違うみたいですね。
    とにかく質問の回答ですが、

    >1.問題の環境から、全ての相手先に対して同様の送信障害がでるのでしょうか。

    送信先は関係ありませんでした。そもそも、送信元のルータで遮断されてしまうので、
    LAN外へメールは出てません・・・。
    (本文は本当に1行と言うか一言程度でないと送れない状態です。)

    >2.PostFixのバージョン。

    2.3.3だったかな?
    ルータで遮断されるためメールサーバーが何かと言うのは関係なかったようです。

    >3.Web Caster V110のファームウェアのバージョン。

    これはごめんなさい。覚えてないです。
    ただ、2007年5月20日現在で最新状態まではUPDATEされてます。
    (当日故障担当者が来てバージョンアップした上でチェックしていましたから)
    ファームウェアの更新日時から調べていただけますでしょうか?

    念のため確認のおさらいですが、この際のメールサーバーは、V110を使用している環境の外部にありました。一言以上のメールを送信すると、メールサーバー上のmaillogには送信元からのコネクトさえも出力されません。つまり外部には出ていないと判断していいと思います。
    もし、サーバー上に何かしらのログが残っているようならば、状況は異なります。送信元のサーバーまたは転送先のサーバーの問題の可能性が高まります。

    コメントに書かれた内容からするとOP25Bの疑いがあると思いますよ。
    OP25Bは、全てを排除するのではなく、容量の少ないメールであれば問題なく送信してくれるところが多いようです。また、送信先が固定IP/変動IPかでも送信できない場合もあります。排除対象についてはそれぞれのプロバイダに詳しい説明がありますので調べてみてください。

    ハマってしまった場合は、調べた内容をまとめて見直してみると、結構状況が限定できるものです。いちよう同じようなチェックだと思うので、本文の方も参考にしてみてください。

    わからないこと調べるのはキツイですが、イロイロと覚えることができるチャンスなので、がんばってください。他になんか役にたちそうなら質問してください。
    そのかわり原因がわかったら、状況を教えてくださるとうれしいです。

    コメント by admin — 2007年8月15日 @ 11:02 PM

この投稿へのコメントの RSS フィード。 TrackBack URI

コメントする

*

Copyright (c) 2007 njcFactory All rights reserved.
HTML convert time: 0.286 sec
Images is enhanced with WordPress Lightbox JS by Zeo
Powered by WordPress.